using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(?<=itemid=)([0-9]{1,2}).*";
string substitution = @"_ITEMID_START_\1_ITEMID_END_";
string input = @"itemid=44'>Red Flower</a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}