use strict;
my $str = 'itemid=44\'>Red Flower</a>';
my $regex = qr/.*(?<=itemid=)([0-9]{1,2}).*/mp;
my $subst = '_ITEMID_START_\\1_ITEMID_END_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";