# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<[^>]*>)/\\b$1\\b/gm;t' <<< "< Jens > is my name. I play < Football >. I saw < Steffy > Yesterday. Yeah, We will be < Together > For sure."