$re = '/(<[^>]*>)/m';
$str = '< Jens > is my name. I play < Football >. I saw < Steffy > Yesterday. Yeah, We will be < Together > For sure.';
$subst = "\\b$1\\b";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;