use strict;
my $str = '< Jens > is my name. I play < Football >. I saw < Steffy > Yesterday. Yeah, We will be < Together > For sure.';
my $regex = qr/(<[^>]*>)/mp;
my $subst = '\\\\b$1\\\\b';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";