// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<[^>]*>)").unwrap();
let string = "< Jens > is my name. I play < Football >. I saw < Steffy > Yesterday. Yeah, We will be < Together > For sure.";
let substitution = "\\\\b$1\\\\b";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}