const regex = /(<[^>]*>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<[^>]*>)', 'gm')
const str = `< Jens > is my name. I play < Football >. I saw < Steffy > Yesterday. Yeah, We will be < Together > For sure.`;
const subst = `\\b$1\\b`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);