import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.*?)( )";
final String string = "This is a sentence\n"
+ "Another sentence shall follow up\n"
+ "And yet a third sentence\n\n"
+ "The goal of these sentences is to show \n"
+ "first spaces that pop up in different line positions\n"
+ "then we'll use regular expressions to \n"
+ "select that first space and then replace that space with \n"
+ "first your insert character and then that space. \n"
+ " This one starts with a space just to cover that\n"
+ " useage scenario\n";
final String subst = "\\1#\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}