const regex = /(^.*?)( )/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.*?)( )', 'gm')
const str = `This is a sentence
Another sentence shall follow up
And yet a third sentence
The goal of these sentences is to show
first spaces that pop up in different line positions
then we'll use regular expressions to
select that first space and then replace that space with
first your insert character and then that space.
This one starts with a space just to cover that
useage scenario
`;
const subst = `\1#\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);