#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!(def\s))(?<=^|\s)[a-zA-Z_][\w_]*(?=\()"
Local $sString = "def anyfunc(vars...):" & @CRLF & _
" pass" & @CRLF & _
"" & @CRLF & _
" _other_func2(vars...)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")