import re
regex = re.compile(r"(?<!(def\s))(?<=^|\s)[a-zA-Z_][\w_]*(?=\()", flags=re.MULTILINE)
test_str = ("def anyfunc(vars...):\n"
" pass\n\n"
" _other_func2(vars...)")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")