using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!(def\s))(?<=^|\s)[a-zA-Z_][\w_]*(?=\()";
string input = @"def anyfunc(vars...):
pass
_other_func2(vars...)";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}