const regex = /(?<!(def\s))(?<=^|\s)[a-zA-Z_][\w_]*(?=\()/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!(def\\s))(?<=^|\\s)[a-zA-Z_][\\w_]*(?=\\()', 'm')
const str = `def anyfunc(vars...):
pass
_other_func2(vars...)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}