$re = '/(?<!(def\s))(?<=^|\s)[a-zA-Z_][\w_]*(?=\()/m';
$str = 'def anyfunc(vars...):
pass
_other_func2(vars...)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);