#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(http:|https:|)\/\/(player.|www.)?(vimeo\.com|youtu(be\.com|\.be|be\.googleapis\.com))\/(video\/|embed\/|watch\?v=|v\/)?([A-Za-z0-9._%-]*)(\&\S+)?"
Local $sString = "https://youtu.be/wOgIkxAfJsk" & @CRLF & _
"http://player.vimeo.com/video/25451551" & @CRLF & _
"http://vimeo.com/25451551" & @CRLF & _
"https://youtube.googleapis.com/v/My2FRPA3Gf8" & @CRLF & _
"http://youtu.be/My2FRPA3Gf8" & @CRLF & _
"http://www.youtube.com/watch?v=My2FRPA3Gf8" & @CRLF & _
"//player.vimeo.com/video/25451551"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")