import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http:|https:|)\\/\\/(player.|www.)?(vimeo\\.com|youtu(be\\.com|\\.be|be\\.googleapis\\.com))\\/(video\\/|embed\\/|watch\\?v=|v\\/)?([A-Za-z0-9._%-]*)(\\&\\S+)?";
final String string = "https://youtu.be/wOgIkxAfJsk\n"
+ "http://player.vimeo.com/video/25451551\n"
+ "http://vimeo.com/25451551\n"
+ "https://youtube.googleapis.com/v/My2FRPA3Gf8\n"
+ "http://youtu.be/My2FRPA3Gf8\n"
+ "http://www.youtube.com/watch?v=My2FRPA3Gf8\n"
+ "//player.vimeo.com/video/25451551";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}