# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http:|https:|)\/\/(player.|www.)?(vimeo\.com|youtu(be\.com|\.be|be\.googleapis\.com))\/(video\/|embed\/|watch\?v=|v\/)?([A-Za-z0-9._%-]*)(\&\S+)?"
test_str = ("https://youtu.be/wOgIkxAfJsk\n"
"http://player.vimeo.com/video/25451551\n"
"http://vimeo.com/25451551\n"
"https://youtube.googleapis.com/v/My2FRPA3Gf8\n"
"http://youtu.be/My2FRPA3Gf8\n"
"http://www.youtube.com/watch?v=My2FRPA3Gf8\n"
"//player.vimeo.com/video/25451551")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.