// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(http:|https:|)\/\/(player.|www.)?(vimeo\.com|youtu(be\.com|\.be|be\.googleapis\.com))\/(video\/|embed\/|watch\?v=|v\/)?([A-Za-z0-9._%-]*)(\&\S+)?").unwrap();
let string = "https://youtu.be/wOgIkxAfJsk
http://player.vimeo.com/video/25451551
http://vimeo.com/25451551
https://youtube.googleapis.com/v/My2FRPA3Gf8
http://youtu.be/My2FRPA3Gf8
http://www.youtube.com/watch?v=My2FRPA3Gf8
//player.vimeo.com/video/25451551";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}