# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\s?)[^;]+?\s?<([^>]+)>(?:;*$)?/$1$2/gm;t' <<< "Joe Smith <Joe.smith@url.com>; Mary Jones <Mary.Jones@url.com>; Marjorie S. Johnson <mjohnson1@url.com>; James Carl-Smith <James.carl-smith@url.com>;"