#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\s?)[^;]+?\s?<([^>]+)>(?:;*$)?"
Local $sString = "Joe Smith <Joe.smith@url.com>; Mary Jones <Mary.Jones@url.com>; Marjorie S. Johnson <mjohnson1@url.com>; James Carl-Smith <James.carl-smith@url.com>;"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)