package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\s?)[^;]+?\s?<([^>]+)>(?:;*$)?`)
var str = `Joe Smith <Joe.smith@url.com>; Mary Jones <Mary.Jones@url.com>; Marjorie S. Johnson <mjohnson1@url.com>; James Carl-Smith <James.carl-smith@url.com>;`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}