import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s?)[^;]+?\\s?<([^>]+)>(?:;*$)?";
final String string = "Joe Smith <Joe.smith@url.com>; Mary Jones <Mary.Jones@url.com>; Marjorie S. Johnson <mjohnson1@url.com>; James Carl-Smith <James.carl-smith@url.com>;";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}