const regex = /(\s?)[^;]+?\s?<([^>]+)>(?:;*$)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s?)[^;]+?\\s?<([^>]+)>(?:;*$)?', 'gm')
const str = `Joe Smith <Joe.smith@url.com>; Mary Jones <Mary.Jones@url.com>; Marjorie S. Johnson <mjohnson1@url.com>; James Carl-Smith <James.carl-smith@url.com>;`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);