import Foundation
let pattern = #"(\s?)[^;]+?\s?<([^>]+)>(?:;*$)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Joe Smith <Joe.smith@url.com>; Mary Jones <Mary.Jones@url.com>; Marjorie S. Johnson <mjohnson1@url.com>; James Carl-Smith <James.carl-smith@url.com>;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)