#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^\\]|\\\\)\*(.*?)([^\\]|\\\\)\*"
Local $sString = "\\\*some number \* other number* more text" & @CRLF & _
""
Local $sSubst = "$1<s>$2$3</s>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)