package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\\]|\\\\)\*(.*?)([^\\]|\\\\)\*`)
var str = `\\\*some number \* other number* more text
`
var substitution = "$1<s>$2$3</s>"
fmt.Println(re.ReplaceAllString(str, substitution))
}