// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^\\]|\\\\)\*(.*?)([^\\]|\\\\)\*").unwrap();
let string = "\\\\\\*some number \\* other number* more text
";
let substitution = "$1<s>$2$3</s>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}