$re = '/([^\\\\]|\\\\\\\\)\*(.*?)([^\\\\]|\\\\\\\\)\*/m';
$str = '\\\\\\*some number \\* other number* more text
';
$subst = "$1<s>$2$3</s>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;