re = /([^\\]|\\\\)\*(.*?)([^\\]|\\\\)\*/m
str = '\\\\\\*some number \\* other number* more text
'
subst = '$1<s>$2$3</s>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result