const regex = /([^\\]|\\\\)\*(.*?)([^\\]|\\\\)\*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\\\]|\\\\\\\\)\\*(.*?)([^\\\\]|\\\\\\\\)\\*', 'gm')
const str = `\\\\\\*some number \\* other number* more text
`;
const subst = `$1<s>$2$3</s>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);