# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\*([^\*]+?)\*(?!\*)/<strong>$1<\/strong>/gm;t' <<< "Lorem *ipsum dolor* sit amet, consectetur adipisicing elit. Optio repellat ipsa quibusdam ab doloremque accusamus nobis *minima maiores** voluptas, incidunt rerum alias, aliquam ut minus consequatur odio voluptatibus voluptates exercitationem.
"