re = /\*([^\*]+?)\*(?!\*)/m
str = 'Lorem *ipsum dolor* sit amet, consectetur adipisicing elit. Optio repellat ipsa quibusdam ab doloremque accusamus nobis *minima maiores** voluptas, incidunt rerum alias, aliquam ut minus consequatur odio voluptatibus voluptates exercitationem.
'
subst = '<strong>$1</strong>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result