import Foundation
let pattern = #"\*([^\*]+?)\*(?!\*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Lorem *ipsum dolor* sit amet, consectetur adipisicing elit. Optio repellat ipsa quibusdam ab doloremque accusamus nobis *minima maiores** voluptas, incidunt rerum alias, aliquam ut minus consequatur odio voluptatibus voluptates exercitationem.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<strong>$1</strong>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)