use strict;
my $str = 'Lorem *ipsum dolor* sit amet, consectetur adipisicing elit. Optio repellat ipsa quibusdam ab doloremque accusamus nobis *minima maiores** voluptas, incidunt rerum alias, aliquam ut minus consequatur odio voluptatibus voluptates exercitationem.
';
my $regex = qr/\*([^\*]+?)\*(?!\*)/mp;
my $subst = '<strong>$1</strong>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";