$re = '/\*([^\*]+?)\*(?!\*)/m';
$str = 'Lorem *ipsum dolor* sit amet, consectetur adipisicing elit. Optio repellat ipsa quibusdam ab doloremque accusamus nobis *minima maiores** voluptas, incidunt rerum alias, aliquam ut minus consequatur odio voluptatibus voluptates exercitationem.
';
$subst = "<strong>$1</strong>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;