using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\d ])[()-]+ *";
string substitution = @"";
string input = @"firstname lastname (123) 456-7890
firstname lastname (234) 567-8910
firstname last-name 345-678-9101";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}