use strict;
my $str = 'firstname lastname (123) 456-7890
firstname lastname (234) 567-8910
firstname last-name 345-678-9101';
my $regex = qr/(?<=[\d ])[()-]+ */ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";