const regex = new RegExp('(?<=[\\d ])[()-]+ *', 'gi')
const str = `firstname lastname (123) 456-7890
firstname lastname (234) 567-8910
firstname last-name 345-678-9101`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);