re = /(?<=[\d ])[()-]+ */i
str = 'firstname lastname (123) 456-7890
firstname lastname (234) 567-8910
firstname last-name 345-678-9101'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result