# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)Bob(?!\S)/@$0/gm;t' <<< "Hi Bob @me
Hi Bobby @me
Hi $Bobby @me
^Bob"