import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)Bob(?!\\S)";
final String string = "Hi Bob @me\n"
+ "Hi Bobby @me\n"
+ "Hi $Bobby @me\n"
+ "^Bob";
final String subst = "@$0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}