import re
regex = re.compile(r"(?<!\S)Bob(?!\S)", flags=re.MULTILINE)
test_str = ("Hi Bob @me\n"
"Hi Bobby @me\n"
"Hi $Bobby @me\n"
"^Bob")
subst = "@$0"
result = regex.sub(subst, test_str)
if result:
print(result)