using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)Bob(?!\S)";
string substitution = @"@$0";
string input = @"Hi Bob @me
Hi Bobby @me
Hi $Bobby @me
^Bob";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}