re = /(?<!\S)Bob(?!\S)/m
str = 'Hi Bob @me
Hi Bobby @me
Hi $Bobby @me
^Bob'
subst = '@$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result