$re = '/(?<!\S)Bob(?!\S)/m';
$str = 'Hi Bob @me
Hi Bobby @me
Hi $Bobby @me
^Bob';
$subst = "@$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;