using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=#).*?([A-Z]\S+)|(?!^)\G.*?([A-Z]\S+)";
string input = @"# FirstWordInHeading another Word
# test Sentence. Test sentence
## test1 Test2 Test3
### Test1 Test2 Test3
## test1 test2 test3
Test1 # test2 Test3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}