$re = '/(?<=#).*?([A-Z]\S+)|(?!^)\G.*?([A-Z]\S+)/m';
$str = '# FirstWordInHeading another Word
# test Sentence. Test sentence
## test1 Test2 Test3
### Test1 Test2 Test3
## test1 test2 test3
Test1 # test2 Test3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);