import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=#).*?([A-Z]\\S+)|(?!^)\\G.*?([A-Z]\\S+)";
final String string = "# FirstWordInHeading another Word\n"
+ "# test Sentence. Test sentence\n"
+ "## test1 Test2 Test3\n"
+ "### Test1 Test2 Test3\n"
+ "## test1 test2 test3\n"
+ "Test1 # test2 Test3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}