import Foundation
let pattern = ##"(?<=#).*?([A-Z]\S+)|(?!^)\G.*?([A-Z]\S+)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ####"""
# FirstWordInHeading another Word
# test Sentence. Test sentence
## test1 Test2 Test3
### Test1 Test2 Test3
## test1 test2 test3
Test1 # test2 Test3
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)