re = /(?<=#).*?([A-Z]\S+)|(?!^)\G.*?([A-Z]\S+)/m
str = '# FirstWordInHeading another Word
# test Sentence. Test sentence
## test1 Test2 Test3
### Test1 Test2 Test3
## test1 test2 test3
Test1 # test2 Test3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end